Problemi con Visual editor di WordPress 2.5

Vi propongo la soluzione per risolvere il problema relativo al visual editor di wordpress 2.5.

Gli errori riscontrati erano

illegal character

tinyMCE is not defined

Questo errore è dovuto a una questione di compressioni di file. In effetti deve essere attivo il modulo su Apache sul file php.ini

Per controllare se è attiva la compressione andare su:

[tuo sito]/wp-includes/js/tinymce/tiny_mce_config.php

Dovrebbe visualizzarsi un testo del tipo che incomincia con “var tinyMCEPreInit = …” e finisce con l’ultima linea che icomincia “tinyMCE.init({mode:”none”,…”.

Se così non è modificare tiny_mce_config.php presente nella cartella [indirizzo blog]/wp-includes/js/tinymce/

Modificando 'compress' => true in compress' => false.

o preferibilmente scaricare un piccolo plugin che disabilita la cache e la compressione quando attiva, che io onestamente non ho usato. http://www.laptoptips.ca/wpd/wp-content/img/testing-tinymce-3.zip

Per sicurezza eliminare il file presente su:

[nome blog]/wp-content/uploads/js_cache/

per svuotare la cache del visual editor javascript

3 commenti su “Problemi con Visual editor di WordPress 2.5”

Lascia un commento